Email sending from SOS Inventory is degraded

Incident Report for SOS Inventory

Identified

We have moved email services to a backup provider while our main service provider is investigating the outage. This should allow email to resume normal delivery.
Posted Jun 27, 2025 - 16:26 CDT

Investigating

The service provider we use for sending emails from SOS Inventory is having an issue currently. We are investigating the issue and will update as soon as we have more information.
Posted Jun 27, 2025 - 15:07 CDT
This incident affects: SOS Inventory (Main).